[zeromq-dev] disconnect behaviour (bug?)

Apostolis Xekoukoulotakis xekoukou at gmail.com
Sun Nov 18 20:28:48 CET 2012


It's ok. I dont really need it. I was using it because I am not sure of the
zsocket_connect behaviour when you execute it for the same endpoint
multiple times.
 I might have to keep track of the connections state.

2012/11/18 Pieter Hintjens <ph at imatix.com>

> Hi Apostolis,
>
> I've created an issue for this:
> https://zeromq.jira.com/browse/LIBZMQ-470#comment-17119
>
> and a test case: https://github.com/zeromq/issues/blob/master/470/issue.c
>
> You may be able to work around by binding the router and connecting
> the dealer, and then destroying / recreating the dealer when needed.
>
> -Pieter
>
> On Sun, Nov 18, 2012 at 8:43 AM, Apostolis Xekoukoulotakis
> <xekoukou at gmail.com> wrote:
> > When I have a zmsg_recv before a disconnect, ZMQ loses one msg.
> >
> > If I remove the disconnect, the msg is not lost.
> >
> >
> > latest czmq, libzmq
> > linux
> >
> >
> > http://pastebin.com/3Vayhmeb
> >
> >
> >
> > --
> >
> >
> > Sincerely yours,
> >
> >      Apostolis Xekoukoulotakis
> >
> >
> >
> > _______________________________________________
> > zeromq-dev mailing list
> > zeromq-dev at lists.zeromq.org
> > http://lists.zeromq.org/mailman/listinfo/zeromq-dev
> >
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>



-- 


Sincerely yours,

     Apostolis Xekoukoulotakis
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20121118/38d69040/attachment.htm>


More information about the zeromq-dev mailing list