[zeromq-dev] Problem with fileserver / fileclient

Pieter Hintjens ph at imatix.com
Sun Nov 18 18:08:22 CET 2012


You posted the server code twice, I think.

Try increasing the HWM size (pipeline constant) in the server, see if
that changes things. I've seen this happen in some cases, haven't
spent time to figure out the reason yet.

-Pieter


On Mon, Nov 19, 2012 at 1:22 AM, Stathis Gkotsis
<stathis.gkotsis at commsquare.com> wrote:
> Hello,
>
>    I am using zeromq v3.2.1-RC2 on Ubuntu 10.04 / Ubuntu 12.04 64bit. I created two simple apps: one fileserver and one fileclient, based on the "File Transfer" example code in the documentation (http://zguide.zeromq.org/page:all#header-151 , model 3). The code for these two example apps can be found here: http://pastebin.com/AuGU9EDC and here: http://pastebin.com/LusbjGCa . As you can see, I use a file of 100KB.
>
> The problem is that when I start the server and then run the client multiple times, sometimes it receives less than 102400 bytes, like: 98304 or 94208 or 90112 bytes. For example, when I run the client 1000 times with an interval of 100ms between the runs, for 970 runs it receives 12400 bytes, while for the rest (30 runs) it receives less bytes. I am bit puzzled by this, could you help?
>
> Thanks,
> Stathis
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev



More information about the zeromq-dev mailing list