[zeromq-dev] Compatibility 3.1 - 3.2.1-rc2

Pieter Hintjens pieterh at gmail.com
Thu Nov 15 13:26:59 CET 2012


So the 3.1 release is problematic, it uses the old wire protocol but does
subscription upstreaming. The strategy we're using now can't recognize this
mix. If anyone wants to take a look at the protocol and see if there's a
solution...

I think we may have to consider 3.1 as an incompatible version. It should
not have been released as stable with this incompatibility.

Pieter

Let's
On Nov 15, 2012 7:16 PM, "Ian Barber" <ian.barber at gmail.com> wrote:

>
>
> On Thu, Nov 15, 2012 at 9:50 AM, Emmanuel TAUREL <taurel at esrf.fr> wrote:
>
>>
>>  From previous Pieter answer, I understood that the 4 cases should work
>> (I hope so).
>> Do I have to create a Jira bug entry for the coming 3.2.1 (stable)?
>>
>
> Definitely raise this, there's nothing that changed that should make them
> incompatible afaik.
>
> Ian
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20121115/ff3ca26f/attachment.htm>


More information about the zeromq-dev mailing list