[zeromq-dev] Compatibility 3.1 - 3.2.1-rc2

Emmanuel TAUREL taurel at esrf.fr
Thu Nov 15 10:50:20 CET 2012


Hello all,

On 14/11/2012 16:10, Pieter Hintjens wrote:
> Yes, these should be compatible. But it's worth checking.
>
> -Pieter

As advised by Pieter, I have made further checking on this point.
My conclusion is that it does not work!

If both pub/sub processes uses 3.1.0, it works
If both pub/sub processes uses 3.2.1-rc2, it also works
But,
if pub uses 3.1.0 and sub uses 3.2.1-rc2, it does not work
If pub uses 3.2.1-rc2 and sub uses 3.1.0 it works but not for the first 
message!

 From previous Pieter answer, I understood that the 4 cases should work 
(I hope so).
Do I have to create a Jira bug entry for the coming 3.2.1 (stable)?

Regards

Emmanuel

>
> On Thu, Nov 15, 2012 at 12:06 AM, Emmanuel TAUREL <taurel at esrf.fr> wrote:
>> Hello all,
>>
>> Is there any compatibility between a publisher using ZMQ 3.1.0 and
>> subscriber(s) using ZMQ 3.2.1-rc2 (running on different hosts)?
>>
>> In case there is no compatibility between these two releases, I assume
>> that it will be the same for future stable release.
>> Is this true?
>>
>> Thank's very much for your answers
>>
>> Emmanuel
>>
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev





More information about the zeromq-dev mailing list