[zeromq-dev] jzmq, Empty messages with PubSub example

Oliver Schrenk oliver.schrenk at gmail.com
Mon Nov 12 10:32:32 CET 2012


@Pieter
No. I don't have experiences in this field

@Min

Reinstalling libzmq from source using [1] solved the failing Maven unit tests but the problem with empty messages still persists

	brew remove zeromq
	git clone git://github.com/zeromq/libzmq.git
	cd libzmq/
	./autogen.sh
	./configure
	make
	make install

So only thing I had to to was (as with the home-brew installation) was to create a symbolic link

	 ln -s /usr/local/lib/libzmq.3.dylib /usr/local/lib/libzmq.1.dylib

as testing the installation with perf failed at first
	
	cd perf
	java -Djava.library.path=/usr/local/lib -classpath /usr/local/share/java/zmq.jar:../src/zmq.jar:zmq-perf.jar local_lat tcp://127.0.0.1:5555 1 100
	...
	Library not loaded: /usr/local/lib/libzmq.1.dylib
	  Referenced from: /usr/local/lib/libjzmq.0.dylib

I reported this bug at [2].

I recompiled jzmq

	cd ../jzmq
	make clean
	make
	make install
	export JAVA_HOME=`/usr/libexec/java_home -v 1.7`
	mvn clean install

and rebuild my application but still get empty error messages.


[1] git://github.com/zeromq/libzmq.git
[2] https://github.com/zeromq/jzmq/issues/135


Am 12.11.2012 um 10:06 schrieb Yu Dongmin <miniway at gmail.com>:

> I couldn't reproduce the test failure on jzmq in my macbook having osx 10.8.2.
> 
> The differences is that I installed libzmq from the git not by the brew.
> 
> Cloud you please clean old lbzmq shared objects and build/install from the latest libzmq/zeromq3-x git ?
> 
> 
> Thanks
> Min
> 
> On Nov 12, 2012, at 5:11 PM, Pieter Hintjens <ph at imatix.com> wrote:
> 
>> On Mon, Nov 12, 2012 at 4:58 PM, Oliver Schrenk <Oliver.Schrenk at gmx.net> wrote:
>> 
>>> I'm trying to run zeromq using the Java bindings, but have trouble getting it to
>>> work. The pubsub example on [1][2], compiles and run but produces only zero length
>>> messages.
>> 
>> The psenvpub/sub examples seem fine, I'd definitely get those working
>> before doing more.
>> 
>> Do you have an experience with JNI, to debug what it happening in jzmq?
>> 
>> -Pieter
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
> 
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20121112/e72f2916/attachment.htm>


More information about the zeromq-dev mailing list