[zeromq-dev] cannot get jzmq to build

isaac flemming elixic at hotmail.com
Tue May 8 01:48:38 CEST 2012

If this is the wrong place to ask this question please feel free to chastise me and/or direct me to a better place, but I am currently stuck on how to get jzmq to build.
I am running on redhat Server 5.6 (Tikanga)The steps I am taking to get it to work are here.
cd to zeromq-2.1.7/1.) build and install 0mq. a.) ./conifgure b.) make b.) sudo make install c.) sudo /sbin/ldconfig
cd to zeromq-jzmq (most recent copy)1.) try to build jzmq a.) ./autogen.sh b.) ./configure or ./configure --with-zeromq=/usr/local   -- error  checking for zmq_init in -lzmq... no  configure: error: cannot link with -lzmq
I have tried building multiple versions of zeromq and jzmq. I have tried setting LD_LIBRARY_PATH, PKG_CONFIG_PATH envirionment variables. I have also tried to install zerom into the /usr/lib directory instead of /usr/local/lib. Pretty much everything I try results in the same thing and every post I find when checking google tells me to make sure to sudo make install and sudo ldconfig, which I am doing.
I wish I could give more info on this, but I really do not have much more, it seems like a pretty straight forward installation, and all the instructions are easy to follow. It all worked for me on unbunto, but we have a prodcution cluster we need to get it installed on running redhat server and it is failing to build on there.
Any help or idea's are greatly appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120507/8ab1907c/attachment.htm>

More information about the zeromq-dev mailing list