[zeromq-dev] Backport of ZMQ_RCVTIMEO/ZMQ_SNDTIMEO to 2.1.x

Andrew Hume andrew at research.att.com
Sat Mar 31 18:16:19 CEST 2012


i am wedded to 2.1.x for the forseeable future.
all i need is backwards compatible.

On Mar 31, 2012, at 8:48 AM, Pieter Hintjens wrote:

> On Fri, Mar 30, 2012 at 8:00 PM, MinRK <benjaminrk at gmail.com> wrote:
> 
>> Does adding to the API/ABI really make sense at this late point in the 2.1.x
>> series?  This will be the first such change since the first stable 2.1
>> release, as far as I know.
> 
> True, but there seems nothing wrong with improving 2.1 stable as long
> as there are people using it. It really depends on the risk of the
> change vs. its benefit.
> 
>> I thought patch releases were only meant to contain bugfixes, etc., not API
>> expansion.  It's fine if API/ABI are officially not fixed per major.minor,
>> but that seems to have been practice until this point, even if only by
>> coincidence.
> 
> We've been moving away from the notion that the ABI version defines
> the product version, towards gradual improvement with
> backwards-compatibility guarantees. This seems more robust and less
> painful.
> 
> Does anyone have strong opinions either way?
> 
> -Pieter
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
> 


------------------
Andrew Hume  (best -> Telework) +1 623-551-2845
andrew at research.att.com  (Work) +1 973-236-2014
AT&T Labs - Research; member of USENIX and LOPSA




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120331/b62fafcb/attachment.htm>


More information about the zeromq-dev mailing list