[zeromq-dev] Building czmq without first installing zeromq

Cedric Krumbein C.Krumbein at F5.com
Fri Jun 22 02:22:49 CEST 2012

Am I to assume from that, that building czmq without first installing zeromq isn't supported?


-----Original Message-----
From: Stephen Hemminger [mailto:shemminger at vyatta.com] 
Sent: Thursday, June 21, 2012 5:21 PM
To: ZeroMQ development list
Cc: Cedric Krumbein
Subject: Re: [zeromq-dev] Building czmq without first installing zeromq

On Fri, 22 Jun 2012 00:08:21 +0000
Cedric Krumbein <C.Krumbein at F5.com> wrote:

> I'm new to zeromq.  I'm currently trying build both zeromq-2.2.0 and czmq-1.1.0.  I'm not allowed to install either one.  I've successfully built zeromq, but I'm not able to build czmq.  When I run czmq's configure script, it says "cannot link with -lzmq, install libzmq".  I've tried various combinations of -with-libzmq and LD_LIBRARY_PATH, all without success.  Can someone advise me on how to build czmq without installing zeromq?
> Thanks in advance,
> Cedric

Get a real IT department, or better yet build in a VM where you can install what you want.

More information about the zeromq-dev mailing list