[zeromq-dev] SEHException when calling zmq_init from clrzmq

Tom Robinson Tom.Robinson at artesiansolutions.com
Mon Jun 18 17:47:47 CEST 2012

Steven, Peter,

> Has it ever worked on this host?  Is it possible to be something mundane like a missing MSVC2010 CRT?  Can you run ZeroMQ applications on the server without a problem?

> -2147467259 is E_FAIL 
> If you are sure that you have the C/C++ runtime libraries installed on this machine (for the same version of MSVC that was used to build libzmq.dll), you could try to remote attach to the IIS process from Visual Studio and see the actual call stack at the moment of this exception.

I'd installed the Microsoft Visual C++ 2010 SP1 Redistributable Package (x64) on the server - is this the correct version? I have very little experience with C++ myself so apologies for any stupid questions around this area.

I have tested some non-web apps and they also seem to be experiencing problems, even on servers where earlier versions of clrzmq worked ok (clrzmq 2.2.3 and libzmq 2.1.11). I need to investigate this in more detail though as the app I'm using to test this isn't very informative when things fail and I'm having trouble remote debugging it.

So hopefully it is as simple as something missing from the environment. My dev machine has Visual Studio 2010 on it and numerous variations of the C++ runtime libraries, which could explain it.

Many thanks,


More information about the zeromq-dev mailing list