[zeromq-dev] Ruby language binding

Chuck Remes cremes.devlist at mac.com
Thu Jan 5 17:01:44 CET 2012


On Jan 5, 2012, at 8:31 AM, Chuck Remes wrote:

> On Jan 5, 2012, at 8:01 AM, Jim Hodapp wrote:
> 
>> I'm trying to run zeromq on a Mac running OS X Lion. I have Xcode installed as which gives me a Ruby installation of version 1.8.7. I have downloaded the latest zeromq stable version, ran ./configure, make and make install. By default it installed to /usr/local. Now I am attempting to install the zeromq Ruby language binding but cannot get it to find my zeromq installation. I have tried several things, but the following 2 are the ones that should work but don't:
>> 
>> sudo gem install zmq
>> 
>> sudo gem install zmq -- --with-zmq-dir=/usr/local/lib
> 
> I've seen this pop up a few times on IRC. I'll try and take a look at it later today. In the meantime, you may want to try ffi-rzmq which is the FFI version of the Ruby bindings (disclaimer: I wrote these bindings). The ffi-rzmq gem works on MRI, JRuby & Rubinius and is just as fast as the C extension.
> 
> I'll post back here if I figure out why the zmq gem is failing to build.

I cannot reproduce the failure. I am using MRI 1.9.2-p136 for the test. 

Give us more details on your environment. 

What Ruby version? (Use ruby -v)

What libzmq version?

Did you use a package manager like macports or homebrew to install?

Plus any other relevant details...

cr




More information about the zeromq-dev mailing list