[zeromq-dev] Issues installing ZeroMQ and PyZMQ on RHEL 6

Justin Cook jhcook at gmail.com
Tue Feb 21 12:57:37 CET 2012

Looks like this is installed outside the standard library path.

$ export LIBRARY_PATH=<dir to libs>

On Tue, Feb 21, 2012 at 6:41 AM, Kushal Dalmia <kdpict at gmail.com> wrote:
> Hi,
> I am a researcher at Carnegie Mellon University and am trying to install
> ZeroMQ with its Python bindings on a RHEL 6 box (Red Hat Enterprise Linux
> Workstation release 6.1 (Santiago)).
> I first tried getting the source from the ZeroMQ website and building it.
> The build finishes successfully and I can see all the required header
> files and libraries in the expected dirs. However, when I write a simple C
> application which links with "-lzmq", the linker fails with a bunch of
> errors (Please see attached file for details).
> I also tried getting and installing the RPM
> (zeromq-2.1.9-1.el6.x86_64.rpm), but get the same issue when trying to
> link to it.
> Please suggest me how to go about this? The same errors are seen when I do
> a "easy_install pyzmq" to install the python bindings.
> Thanks,
> Kushal Dalmia
> Graduate Student
> Carnegie Mellon University

More information about the zeromq-dev mailing list