[zeromq-dev] Issues installing ZeroMQ and PyZMQ on RHEL 6

gonzalo diethelm gdiethelm at dcv.cl
Tue Feb 21 12:46:04 CET 2012

It seems you are missing the C++ development packages in your distribution. I don't know exactly what those are, I have never worked with RHEL.

Gonzalo Diethelm
DCV Chile

> -----Original Message-----
> From: zeromq-dev-bounces at lists.zeromq.org [mailto:zeromq-dev-
> bounces at lists.zeromq.org] On Behalf Of Kushal Dalmia
> Sent: Tuesday, February 21, 2012 3:42 AM
> To: zeromq-dev at lists.zeromq.org
> Subject: [zeromq-dev] Issues installing ZeroMQ and PyZMQ on RHEL 6
> Hi,
> I am a researcher at Carnegie Mellon University and am trying to install
> ZeroMQ with its Python bindings on a RHEL 6 box (Red Hat Enterprise Linux
> Workstation release 6.1 (Santiago)).
> I first tried getting the source from the ZeroMQ website and building it.
> The build finishes successfully and I can see all the required header files and
> libraries in the expected dirs. However, when I write a simple C application
> which links with "-lzmq", the linker fails with a bunch of errors (Please see
> attached file for details).
> I also tried getting and installing the RPM (zeromq-2.1.9-1.el6.x86_64.rpm),
> but get the same issue when trying to link to it.
> Please suggest me how to go about this? The same errors are seen when I do
> a "easy_install pyzmq" to install the python bindings.
> Thanks,
> Kushal Dalmia
> Graduate Student
> Carnegie Mellon University

More information about the zeromq-dev mailing list