[zeromq-dev] zmq_sendv

john skaller skaller at users.sourceforge.net
Thu Feb 9 01:34:00 CET 2012

On 09/02/2012, at 7:49 AM, Nadav Samet wrote:

> Thanks for implementing this, John. One minor comment I have is that the name ZMQ_SNDMORE does not seem right for what it's doing (at least not to me), maybe something like ZMQ_MULTIPART would indicate that the vector should be interpreted as a single multipart message.

Possibly you are right, keep hold of that thought! Or even create a ticket on
the bugtracker to ensure it is kept hold of for discussion.

The reason for ZMQ_SNDMORE is that it is an existing tag so using it minimised
the number of changes required.

It seemed consistent enough, and more changes might threaten the acceptance
of the function. Unfortunately this kind of thing often matters more than
getting it right (my experience on C++ committee again, reusing or
overloading keywords was always preferred to new ones even though this
resulted in C++ having the most disgusting syntax).

john skaller
skaller at users.sourceforge.net

More information about the zeromq-dev mailing list