[zeromq-dev] Network problem: no communications (can I use a sniffer?)

Claudio Carbone erupter at libero.it
Mon Dec 17 15:57:51 CET 2012

Ok sometimes focusing too hard on something makes you a real dumbass...
I was expecting the receiver to receive while subscribing on localhost...
Shame on me.


On 17/12/12 15:36, Claudio Carbone wrote:
> Hello!
> I'm having problems in that my application works with sender and
> receiver on the same machine.
> It does not work when I use two different machines on the same network
> (which by the way is ok as I control one of them via ssh on the same
> network).
> So something is amiss.
> I tried wireshark but I can't find the packets I'm sending.
> I tried filtering with the port and there are no packets originating
> from the port my programs are using.
> Right now I'm using these parameters
> sender:
> tcp://*:5678
> receiver:
> tcp://localhost:5678
> Claudio
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev

More information about the zeromq-dev mailing list