[zeromq-dev] Compatibility 3.2.2 -> 3.2.0-rc1

Sebastian Haglund sebastian at haglund.se
Thu Dec 6 18:15:08 CET 2012


Hi,

I've been working on a project, using zmq 3.2.0-rc1, since this summer and now when 3.2.2 was released I thought it's a good time to upgrade.
But I seem to have some issues with compatibility between the versions. I have a couple of different components running on different hosts/platforms.

3.2.0 -> 3.2.2 seems to work fine (PUSH-PULL) but on the other end (3.2.2 XPUB -> 3.2.0 XSUB) nothing is received. On the pub-side I can see the subscriptions coming in.
I've also noticed the same on REQ-REP, request comes in but the reply is not received on the 3.2.0 end. Works fine if both are on the same version.
So it seems 3.2.0 can't receive data from 3.2.2.

Are there any known issues between the versions?

Regards,
Sebastian


More information about the zeromq-dev mailing list