[zeromq-dev] quick question regarding getting EAGAIN

diffuser78 diffuser78 at gmail.com
Wed Aug 8 20:13:14 CEST 2012


I did a git pull and then git grep'd for this but I can't find this in the
3.x tree ?

Am I missing something ?

On Wed, Aug 8, 2012 at 10:29 AM, Stuart Brandt <stu at compuserve.com> wrote:

> Have you taken a look at the ZMQ_DELAY_ATTACH_ON_CONNECT socket opt that
> came out a couple months ago?
>
> On 08/08/2012 12:23 PM, diffuser78 wrote:
> > Can someone please let me know their thoughts on it ?
> >
> > On Tue, Aug 7, 2012 at 1:55 PM, diffuser78 <diffuser78 at gmail.com
> > <mailto:diffuser78 at gmail.com>> wrote:
> >
> >     Hi,
> >     My app is using a dealer socket, while the remote app is router
> >     socket.From my knowledg after reading zguide is that ZMQ buffers
> >     the message even if the remote app is not bound. Can I change this
> >     behavior in Dealer socket to return me EAGAIN immediately if the
> >     remote app is not bound ? Is this a quick solution to it ?
> >     Many thanks.
> >     DJ
> >
> >
> >
> >
> > _______________________________________________
> > zeromq-dev mailing list
> > zeromq-dev at lists.zeromq.org
> > http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120808/43dad636/attachment.htm>


More information about the zeromq-dev mailing list