[zeromq-dev] ZMQ Freezing Windows

Steve Hawkins shawkins at evosus.com
Tue Aug 7 22:04:14 CEST 2012

ESET is a big beast with many different modules sniffing everything you do and making statistics-based decision. I guess what I'm saying is, are you sure ESET is out of the picture? The failure mode is very telling at any rate. There are only a few things that can bring Windows to its knees as is happening here - one of these is a driver. ESET runs as a driver. I don't think libzmq could do this on its own.


From: zeromq-dev-bounces at lists.zeromq.org [mailto:zeromq-dev-bounces at lists.zeromq.org] On Behalf Of Dave R.
Sent: Tuesday, August 07, 2012 12:54 PM
To: ZeroMQ development list
Subject: Re: [zeromq-dev] ZMQ Freezing Windows

I was really hopeful reading this as I'm also using ESET. But, I disabled it and still got the problem.

However, I have noticed a further pattern. The first time I run it it runs for a little over 1000 iterations then gives the assertion failure and stops.  The second time I run it I get almost the same behaviour but I get a couple of messages displayed AFTER the assertion failure. The third time I run it it processes 70 or so messages then hard locks my PC.

On Tue, Aug 7, 2012 at 5:22 PM, Steve Hawkins <shawkins at evosus.com<mailto:shawkins at evosus.com>> wrote:
Dave, I have experienced the freezing problem you describe with Windows 7. I am using the NUGET package in a Windows service project built with VS 2010. It may freeze with no keyboard and mouse control  and you must perform a power button shutdown. Alternatively it may slow down the UI greatly, when this happens task manager will reveal that the process 'ekrn.exe' (this is ESET) is taking 50% of cpu resources, but Windows behaves like it is taking 99%. I found this post that pointed me in the direction of antivirus, ESET in my case.


If you are using ESET antivirus or some other antivirus make an exception for your executable. In ESET it is found under Advanced setup > Antivirus and antispyware > Exclusions. Add the path to your executable.

- Steve

-----Original Message-----

I've been trying to write a broker using ZMQ and found that it would
occasionally lock my PC totally, requiring a power-off as the usual
Ctrl-Alt-Del etc, and even a shutdown request by pressing the power button
did nothing.
zeromq-dev mailing list
zeromq-dev at lists.zeromq.org<mailto:zeromq-dev at lists.zeromq.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120807/7681db82/attachment.htm>

More information about the zeromq-dev mailing list