[zeromq-dev] ZMQ Freezing Windows

Chuck Remes lists at chuckremes.com
Tue Aug 7 14:29:13 CEST 2012


On Aug 7, 2012, at 3:39 AM, Dave R. wrote:

> Sorry, it looks like what I wrote was not clear. I didn't change the ZMQ stuff, I'm using the packaged library from NuGet.  All I changed was the example code from the ZMQ guide lruqueue2 example to make the "Hello" messages unique. I also set the HWM on all the sockets to 10.
> 
> To be totally clear, the problem is happening with the unmodified sample code from the ZMQ guide and the packaged library.
> 
> ZMessage isn't included in the NuGet library so I took that from https://github.com/imatix/zguide/blob/master/examples/C%23/zmsg.cs.
> 
> The example code (  http://zguide.zeromq.org/cs:lruqueue2  ) creates 10 clients (1 socket each) and 3 workers (also 1 socket each) and a broker (2 sockets) so the total number of sockets used is 15. The code doesn't do anything silly like keep recreating the sockets so only 15 sockets are being created.

I don't know what else to suggest. I run a broker and a dozen or so clients on Win7x64 every day that pump a few hundred million messages around. I have not run into this issue.

However, I have never used the .NET bindings (I use the Ruby bindings) so there's an obvious difference there.

Hopefully someone else on the list has an idea for you to try.

cr

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120807/afa65fcc/attachment.htm>


More information about the zeromq-dev mailing list