[zeromq-dev] ZMQ Freezing Windows

Dave Rutlidge anemailfordave at gmail.com
Tue Aug 7 09:28:51 CEST 2012


Thanks for that. I set the HWM at 10 for all the sockets. When I ran it I
still got the assertion failure after a short time (couple of seconds, if
that):

Assertion failed: fds.size () <= FD_SETSIZE (..\..\..\src\select.cpp:69)

I changed the code to add a number to the "Hello" message. I got the
assertion after about 1027 messages sent. Running the same .exe a second
time I got similar results. However the third time it only got to 27 then
the machine froze requiring a hard reboot. (BTW I left the frozen machine
overnight and it never came back).

I had Process Monitor running the whole time to check RAM (plenty available
and it didn't go up to any measurable extent) and in the hope of killing
the process if it went rouge - no chance :(


On Mon, Aug 6, 2012 at 11:30 PM, Chuck Remes <lists at chuckremes.com> wrote:

>
> On Aug 6, 2012, at 5:03 PM, Dave Rutlidge wrote:
>
> I've been trying to write a broker using ZMQ and found that it would
> occasionally lock my PC totally, requiring a power-off as the usual
> Ctrl-Alt-Del etc, and even a shutdown request by pressing the power button
> did nothing.
>
> I tried simpler and simpler examples and still have the same things
> happen. In the end I tried building the example code from The Guide.  I
> tried the lruqueue2 example code (C# version) and got a whole set of HELLO
> and OK messages, the they slowed and stalled.  Then the console froze, then
> explorer, then the mouse. One dead PC. Out of interest, I left it to see if
> it would ever come back - it hasn't after an hour.
>
> One time, when I ran the built code and got an assertion failure (sorry, I
> don't know what it was right now). When I Googled it it was about Windows
> not allowing more than 64 (?) handles by default and suggested changing a
> constant and recompiling. I don't know if that's related.
>
> I'm using the NuGet package (http://nuget.org/packages/clrzmq) v 2.2.5 on
> a Windows 7 Pro machine and the VS2012RC.  I've tried both the 16 & 32 bit
> versions of the library.
>
> Any ideas?
>
>
> My guess is that you are running code that is building up a queue so large
> that it consumes all RAM on the machine. For *every* zeromq socket you are
> creating, please set a high water mark to a small value like 100. Then run
> your code again.
>
> Fire up the task manager and watch RAM consumption. If you see it spiking
> to a large percentage of your machine's capacity, kill it.
>
> cr
>
>
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120807/0d8fd61f/attachment.htm>


More information about the zeromq-dev mailing list