[zeromq-dev] Error While Building pyzmq

Gargi Das gargi.das at hotmail.com
Tue Apr 24 08:58:00 CEST 2012

Hello MinRK

Just to add more information, i tried building it on debug python of win32 version and there also it gives me same error ??

The linker somehoe tries to link against python31.lib which is wrong it should link against python31_d.lib.

CC: zeromq-dev at lists.zeromq.org
From: benjaminrk at gmail.com
Date: Mon, 23 Apr 2012 23:34:24 -0700
To: zeromq-dev at lists.zeromq.org
Subject: Re: [zeromq-dev] Error While Building pyzmq

Wow, debug Python 3 on 64b Windows is *far* outside my home court.
I guess my first question would have to be: can you build other extensions properly?

On Apr 23, 2012, at 23:04, Gargi Das <gargi.das at hotmail.com> wrote:

Hello All,

I am facing a problem when i am trying to build pyzmq for a debug version of python.

I do the following steps:

1. build libzmq using visual studio the configuration selected is Win64 and debug.
2. cd into pyzmq directory and configure libzmq and pyzmq with command : python_d.exe setup.py configure --zmq="my zmq path"
3. now using the same python_d.exe i try to call: python_d.exe setup.py install

Step three gives me an error :

running install

running build

running build_py

copying zmq\libzmq.dll ->

running build_ext

building 'zmq.core.constants' extension

C:\Program Files (x86)\Microsoft Visual Studio
9.0\VC\BIN\amd64\cl.exe /c /nologo /Ox /MD /W3 /GS- /DNDEBUG

-2.1.11\zeromq-2.1.11\include -Izmq\utils -Izmq\core

/Tczmq\core\constants.c /Fobuild\temp.



zmq\utils\zmq_compat.h(130) : warning C4067: unexpected
tokens following preprocessor directive - expected a newline

C:\Program Files (x86)\Microsoft Visual Studio
9.0\VC\BIN\amd64\link.exe /DLL /nologo /INCREMENTAL:NO


libzmq.lib /EXPORT:PyInit_constants build\temp.win-amd64



LINK : fatal error LNK1104: cannot open file 'python31.lib'

error: command '"C:\Program Files (x86)\Microsoft
Visual Studio 9.0\VC\BIN\amd64\link.exe"' failed with exit status 1104

[74795 refs]

Important line in above log is LINK : fatal error
LNK1104: cannot open file 'python31.lib'


Now my question is why setup.py is trying to open
python31.lib it should try to open python31_d.lib.  Do i need to do some changes in any of the config files i tried to find that but was not able to find it.
Just for saying i was able to build , libzmq and pyzmq for release version of python.
I will be grateful if anyone can help me on this ??

zeromq-dev mailing list
zeromq-dev at lists.zeromq.org

zeromq-dev mailing list
zeromq-dev at lists.zeromq.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120423/d281a1be/attachment.htm>

More information about the zeromq-dev mailing list