[zeromq-dev] libzmq dylib versioning

Pieter Hintjens ph at imatix.com
Thu Sep 22 18:08:51 CEST 2011


On Wed, Sep 21, 2011 at 5:14 PM, Mikko Koppanen
<mikko.koppanen at gmail.com> wrote:

> the version represents ABI version rather than the library version
> itself. The version is incremented when backwards incompatible changes
> happen. What we actually should do is to increment the version in 3.x
> as it seems to be still having the 1.0.0 version.

Does the 3.0 API count as a new version (2.0.0?) Or rather an updated
of version 1?

-Pieter



More information about the zeromq-dev mailing list