[zeromq-dev] Problem with 0mq

Mahathi_Prabhala Mahathi_Prabhala at mahindrasatyam.com
Wed Nov 30 11:37:27 CET 2011

Hi all

We are facing quite a curious issue with ZMQ. A simple server is used to queue files to a client which process the files and queues the results back to the server. This setup works fine without our application code doing the actual processing, but once the application code is incorporated, there is an error in our device driver (part of
our application). What's mystifying is that our application works fine when ZMQ is not used and files are instead read from the disk.

When we run the program with the ZMQ, the system hangs. The debug messages report an error that is, "Unable to handle kernel paging request".
When we commented the memcpy() function call in the driver code it worked fine though we don't understand why a memcpy() function leads to a system crash.
The file that the server sends in is of 2KB.

We are currently working on the Debian distribution of Linux, the kernel version used being 2.6.39.The system configuration is as follows;

Intel Xeon E31245 processor @ 3.3GHz
4 GB RAM and a 250GB 6.0Gb/s SATA Hard Drive.

Can you please help us in finding out where the problem is.

Is it the ZMQ that is being used in our application?
Or is it the application that seems to be causing the problem( though we are clueless as to why it's causing a problem now when it worked fine when the files were read from the disk)?

I have attached the server and client programs for your reference.

Thank you.

Mahathi Prabhala
[cid:image001.gif at 01CB7C07.E8253940]


This email (including any attachments) is intended for the sole use of the intended recipient/s and may contain material that is CONFIDENTIAL AND PRIVATE COMPANY INFORMATION. Any review or reliance by others or copying or distribution or forwarding of any or all of the contents in this message is STRICTLY PROHIBITED. If you are not the intended recipient, please contact the sender by email and delete all copies; your cooperation in this regard is appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20111130/bcafff25/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.gif
Type: image/gif
Size: 4714 bytes
Desc: image001.gif
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20111130/bcafff25/attachment.gif>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ps.c
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20111130/bcafff25/attachment.c>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: pc.c
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20111130/bcafff25/attachment-0001.c>

More information about the zeromq-dev mailing list