[zeromq-dev] ASP.NET Issue

lanre lawal lawillas4ever at yahoo.com
Tue Nov 15 22:40:48 CET 2011


Hi Guys,
    So i've successfully completed a project with the clr-zmq binding for C# on ASP.NET. Now everything works fine when I test my project from Visual Studio 2010 (ctrl + F5). Now I want to distribute the project to other windows users, but when I drop the project folder into the C:/inetput/wwwroot folder and I test it, I get this error that I can't seem to understand. It reads as follows:
Server Error in '/' Application.
________________________________

Could not load file or assembly 'clrzmq' or one of its dependencies. An attempt was made to load a program with an incorrect format.Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.BadImageFormatException: Could not load file or assembly 'clrzmq' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Source Error: 


An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 
Assembly Load Trace: The following information can be helpful to determine why the assembly 'clrzmq' could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].  
Stack Trace: 


[BadImageFormatException: Could not load file or assembly 'clrzmq' or one of its dependencies. An attempt was made to load a program with an incorrect format.] System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) +0 System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection, Boolean suppressSecurityChecks) +567 System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +192 System.Reflection.Assembly.Load(String assemblyString) +35 System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +123
 [ConfigurationErrorsException: Could not load file or assembly 'clrzmq' or one of its dependencies. An attempt was made to load a program with an incorrect format.] System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +11554224 System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +485 System.Web.Configuration.AssemblyInfo.get_AssemblyInternal() +79 System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +337 System.Web.Compilation.BuildManager.CallPreStartInitMethods() +280 System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException) +1167 [HttpException (0x80004005): Could not load file or assembly 'clrzmq' or one of its
 dependencies. An attempt was made to load a program with an incorrect format.] System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11686928 System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +141 System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4863749  
________________________________
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.237


I read somewhere that it has to do with a machine type issue (32bits VS 64bits). But I was wondering why it would work when i'm testing through visual studio and not work when testing through the normal localhost testing. Mind you both testing methods are done on 1single machine which is my machine. Please does someone have an idea of why this might be happening.
 
Regards,
Olanrewaju Lawal
Web Developer / Programmer
+2348053568948
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20111115/304edfaa/attachment.htm>


More information about the zeromq-dev mailing list