[zeromq-dev] ZMQ 2.1.3 w/OpenPGM Assertion on pgm_rate_check2()

Steven McCoy steven.mccoy at miru.hk
Wed Mar 23 13:20:04 CET 2011


On 23 March 2011 20:00, Bob Beaty <drbobbeaty at gmail.com> wrote:

> I've tried for over an hour to get this to configure and had no luck.
>
> I realized that the libpgm-from-trunk.tar.gz needed to be unpacked and
> then:
>  aclocal
> automake --copy --add-missing
> autoconf
> in order to get the configure script for the sub-package. I then tarred it
> all back up and tried it again.
>   OK, it took me quite a while to see what I needed to do to get
> ./configure, but this is what I found.
>   Even with these steps, I can get OpenPGM to configure, but then it's
> saying it can't find Makefile.in, which I know is in the openpgm/pgm/
> directory, but clearly, it's not seeing it.
>
>
To use a non-bundled version copy the tarball into foreign, i.e.

zeromq2-1/
  foreign/
    openpgm/
      libpgm-5.1.115~dfsg.tar.gz

Then run configure as follows:

$ *cd zeromq2-1*
$ *./configure --with-pgm=libpgm-5.1.115~dfsg*

The name needs to match the tarball name.

-- 
Steve-o
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110323/f07a70d1/attachment.htm>


More information about the zeromq-dev mailing list