[zeromq-dev] ZMQ 2.1.3 w/OpenPGM Assertion on pgm_rate_check2()

Bob Beaty drbobbeaty at gmail.com
Wed Mar 23 13:00:35 CET 2011

On Mar 23, 2011, at 3:42 AM, Pieter Hintjens wrote:

> Bob,
> Can you apply Steven's patch as sent to the list today and confirm
> that this fixes your problem?
> Then the fix will go into v2.1.4.

I've tried for over an hour to get this to configure and had no luck.

I realized that the libpgm-from-trunk.tar.gz needed to be unpacked and then:
	automake --copy --add-missing
in order to get the configure script for the sub-package. I then tarred it all back up and tried it again.
  OK, it took me quite a while to see what I needed to do to get ./configure, but this is what I found.
  Even with these steps, I can get OpenPGM to configure, but then it's saying it can't find Makefile.in, which I know is in the openpgm/pgm/ directory, but clearly, it's not seeing it.

> If you have trouble getting this working, let me know and I'll send
> you a full tarball to test.

  If you can tell me what to do to get it to really configure, I'd be glad to, but at this point, I've exhausted all my ideas, and I'm stumped.
  A tarball to test would be OK as well. Anything that allows me to build this and test it.

        Bob (drbobbeaty at gmail.com)
    The Man from S.P.U.D.
    We will write no code before it's designed.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110323/4312854b/attachment.htm>

More information about the zeromq-dev mailing list