[zeromq-dev] Assertion failed: ok (xrep.cpp:173) - SOLVED

Ilja Golshtein ilejncs at narod.ru
Wed Mar 9 11:40:21 CET 2011

I've backported the patch to 2.0.10 in straightforward way (attached).

Unfortunately it does not solve the problem, though significantly
reduce possibility of the crash. 

I've got stuck: 2.0.10 does not work for me, although 2.1.x
is a release candidate and does not seem suitable for production usage.



03.03.2011, 16:10, "Pieter Hintjens" <ph at imatix.com>;:

>  2011/3/3 Ilja Golshtein <ilejncs at narod.ru>;;:
>>   Many thanks to Martin - the issue seems to be solved by his patch.
>>   Sorry for asking (perhaps it is already discussed), but is the patch expected in 2.0 or
>>   I have to switch to 2.1?
>>   Both 2.0 and 2.1 are "stable releases" according to http://www.zeromq.org/intro:get-the-software,
>>   but is 2.0 finalized?
>  If someone wishes to backport the patch to 2.0, test it, and send that
>  to me via this list, I'll get it into 2.0.11.
>  -Pieter
>  _______________________________________________
>  zeromq-dev mailing list
>  zeromq-dev at lists.zeromq.org
>  http://lists.zeromq.org/mailman/listinfo/zeromq-dev
Best regards,
Ilja Golshtein.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xrep_hwm_2.0.10.diff
Type: application/octet-stream
Size: 408 bytes
Desc: not available
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110309/7a561e86/attachment.obj>

More information about the zeromq-dev mailing list