[zeromq-dev] api stability

Martin Sustrik sustrik at 250bpm.com
Tue Jun 28 23:29:20 CEST 2011


On 06/28/2011 05:03 PM, George Coles wrote:

> The breaking changes to the
> api never seem to stop, and changes ripple through the binding projects
> as maintainers try to keep things stable or, sometimes, they change
> their wrapper apis because they have some insight about how to bridge
> the impedence mismatch between zeromq and the target language in a
> better way.

IIRC the last backward-incompatible change has happened between version 
2.0.6 and 2.0.7 ie. at 04/06/2010.

At that point the policy of not doing backward incompatible changes 
unless there's a major version number bump was introduced. Major version 
number haven't changed since.

Can you be more specific about what you are referring to?

Martin




More information about the zeromq-dev mailing list