[zeromq-dev] [PATCH] Remove Windows NT 3.5 support from zeromq2-1

Steven McCoy steven.mccoy at miru.hk
Fri Jun 17 00:50:02 CEST 2011


On 16 June 2011 16:45, Steven McCoy <steven.mccoy at miru.hk> wrote:

> Note that the public headers of ZeroMQ do not support NT 3.5, so it is
> already broken,
>
>
Similarly the bizarre redefinition of _WIN32_WINNT on MinGW32 is inherently
broken as the logic is applied inside *windows.hpp *but then visit
*zmq.h*and now you cannot use
ZMQ_HAVE_MINGW32 as platform.hpp is not getting pulled in but you need to
have *windows.h* to detect WinSock version which means you end up with
mismatched platform SDK definitions.

-- 
Steve-o
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110616/3e90fc3f/attachment.htm>


More information about the zeromq-dev mailing list