[zeromq-dev] Test case for the "Assertion failed: nbytes == sizeof (command_t)" error.

Luc Heinrich luc at honk-honk.com
Sun Jun 12 19:56:55 CEST 2011


On 12 juin 2011, at 19:10, Martin Sustrik wrote:

> That looks like the overflow of mailbox (socektpair) buffers. Try configuring your system to allow for larger buffers.

Looks like the problem was really specific to my OS at this specific moment.

I started to bump the net.inet.tcp.sendspace and net.inet.tcp.recvspace values using sysctl and it started to work as expected. So I changed one of the two values back to its initial value and it still worked. So I changed the other value to its initial state, and IT STILL WORKED!

So I rebooted to make sure I was in a "normal" state, and for the life of me, I can't reproduce the problem at all anymore.

So it looks like I owe the list an apology for the noise, but I'll definitely keep an eye on this orderly shutdown thing ;)

-- 
Luc Heinrich - luc at honk-honk.com




More information about the zeromq-dev mailing list