[zeromq-dev] Problem Compiling Pyzmq

Antonio Teixeira eagle.antonio at gmail.com
Mon Jul 25 22:36:33 CEST 2011

Hello Guys/Gals.

I have tried to install pyzmq in ubuntu 11.04

Linux ubuntu 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011
i686 i686 i386 GNU/Linux

It fails With

running build_ext
building 'zmq.core.constants' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall
-Wstrict-prototypes -fPIC -Izmq/utils -Izmq/core -Izmq/devices
-I/usr/include/python2.7 -c zmq/core/constants.c -o
build/temp.linux-i686-2.7/zmq/core/constants.o -Wno-unused-function
zmq/core/constants.c:4:20: fatal error: Python.h: Unknow File / Dir
compilation terminated.
error: command 'gcc' failed with exit status 1

Installing Cython gave the same error that i was able to solve by using
apt-get instead of easy_install.

Best Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110725/cf027d59/attachment.htm>

More information about the zeromq-dev mailing list