[zeromq-dev] Possible Ubuntu and OpenPGM Problem?

Martin Sustrik sustrik at 250bpm.com
Fri Jan 28 08:00:15 CET 2011

Hi Bob,

> Martin S. saw this and suggested I change line 194 in socket_base.cpp from:
> if ((protocol_ == "pgm" || protocol_ == "epgm") &&
> options.requires_in && options.requires_out) {
> to:
> if ((protocol_ == "pgm" || protocol_ == "epgm") &&
> options.type != ZMQ_PUB && options.type != ZMQ_SUB &&
> options.type != ZMQ_XPUB && options.type != ZMQ_XSUB) {

I've applied this change to the master now.

> And when I did this it cleared up the error I was getting when trying to
> connect (as pointed out in the gist: https://gist.github.com/794827 ) to
> the URL, but no data was received at the SUB side. If I used the 2.1.0
> libs, everything worked fine. If I used the libs from the github
> 'master' dated 09-Dec-2010 then all worked fine.
> So it appears that there are possibly other changes in the code that
> need to be fixed or changed in order to get the PUB/SUB on OpenPGM to be
> working in the github 'master'.

Ok. We are almost doing bissection here... Try using version 
18f29ded6a83875c2739. That was before I've introduced 
subscription-forwarding-related patches.


More information about the zeromq-dev mailing list