[zeromq-dev] assert in epoll.cpp line 71

Zoufal Andreas Andreas.Zoufal at ait.ac.at
Thu Jan 27 12:53:50 CET 2011


thanks for your advice. At first I tried out the development version 2.1.0 from 2010/12/01. In this version the epoll-assert is gone, but sometimes another assert appears:

Client: finished
Server 6: finished
Server 17: finished
Client: finished
Assertion failed: new_sndbuf > old_sndbuf (mailbox.cpp:182)

Next I wil try to get the most accurate version from the repository. You think there are more patches regarding this issue?

Kind regards,

-----Original Message-----
From: Martin Sustrik [mailto:sustrik at 250bpm.com] 
Sent: Thursday, January 27, 2011 8:35 AM
To: ZeroMQ development list
Cc: Zoufal Andreas
Subject: Re: [zeromq-dev] assert in epoll.cpp line 71


> Do you know this behavior? See the attached minimal code.

Some patches that may have solved the issue were introduced lately. Can you retry with the master version of 0MQ from the github?


More information about the zeromq-dev mailing list