[zeromq-dev] MSVC RELEASE Build issue

Biju Chandran chandran.biju007 at gmail.com
Thu Feb 24 10:45:24 CET 2011

Hi Pieter,
              After stripping the code to the basics and adding some(which
should have been there first place. My wrong) exception handling i find
zmq::context_t context (1);
zmq::socket_t subscriber (context, ZMQ_SUB);
        subscriber.setsockopt(ZMQ_SUBSCRIBE, "", 0);
 }catch(error_t e){

CString* recString = new CString;
                DisplayError(*recString );

I tried with the 2.1.1 release (source code downloaded and built at my end)
and also with the latest libs here http://snapshot.zero.mq/msvc2008/ dated

Everything works for a DEBUG build. But for a RELEASE build
"subscriber.connect("epgm://;");" gives 'Protocol not
I am assuming that the openPGM is not being linked rightly for a RELEASE
TCP worked fine for both builds when used with 2.1.1.
But facing inconsistent behavior with 2.1.0 which i had custom built with
openPGM. If it get working on 2.1.1 i can pretty well forget about 2.1.0

On Wed, Feb 23, 2011 at 10:19 PM, Pieter Hintjens <ph at imatix.com> wrote:

> Hi Biju,
> Could you post a minimal test case somewhere?
> Thanks
> Pieter
> On Wed, Feb 23, 2011 at 5:29 PM, Biju Chandran
> <chandran.biju007 at gmail.com> wrote:
> > Hi,
> >     I have a PUB-SUB on windows.
> > The PUB sends data over tcp and epgm. I was working on zmq 2.1.0 custom
> > build for openPGM. Now I have linked to the newly released zmq 2.1.1
> > But strangely, with both versions i face a problem with RELEASE build.
> > The MSVC Debug build works fine and the SUB receives data. But when i try
> > the RELEASE build , the SUB does not receive data. I tried Wireshark to
> > check if the packets are being sent and in RELEASE they are indeed not
> being
> > sent.
> > I dont know if this helps but I am using MSVC2010 and I am serializing
> > Google protobuf messages and sending.
> > Perhaps i would request anyone with a similar setup to try the RELEASE
> > build.
> > Many Thanks,
> > Biju Chandran
> > _______________________________________________
> > zeromq-dev mailing list
> > zeromq-dev at lists.zeromq.org
> > http://lists.zeromq.org/mailman/listinfo/zeromq-dev
> >
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110224/8426d1c2/attachment.htm>

More information about the zeromq-dev mailing list