[zeromq-dev] libuuid in zmq v3

Martin Sustrik sustrik at 250bpm.com
Wed Aug 31 23:33:44 CEST 2011


Hi Elliot,

> I'm trying to compile zmq3.0 on my machine, and I noticed that when I
> ./configure the latest from the git repo on github, configure still
> checks for libuuid.  One of the reasons I wanted to upgrade to zmq3.0
> was to be able to use the 32-bit peer IDs as opposed to the UUIDs in
> previous versions; is this a feature that hasn't been implemented yet,
> or am I grabbing the wrong code?

Unfortunately, UUIDs are needed for the ZMQ_IDENTITY functionality which 
is still present in 3.0.

However, it was removed in the current development trunk (4.0 to be) and 
thus there's no dependency on libuuid:

https://github.com/zeromq/libzmq

Martin



More information about the zeromq-dev mailing list