[zeromq-dev] Switched from 2.1.7 to 3.0.0alpha, XREP to XREP now communication Fails

Rodolfo Narciso Duldulao Jr. rduldulao at chikka.com
Thu Aug 18 04:26:56 CEST 2011


Thanks for the tip MinRK.   I tried adding zmq.ROUTER and DEALER values  and using them in the socket creation but the sending still does not happen.  I reverted back to zeromq2.1.7 and 2.1.8 (and therefore back to using XREP) just to check and it worked just fine, although the double connect halts the program.  I must be missing something.  I will try to build pyzmq 2.1.8 and see how it goes.


On Wed, Aug 17, 2011 at 04:40, Rodolfo Narciso Duldulao Jr. <rduldulao at chikka.com> wrote:

Thanks for the reply.

Hi Rodolfo,
  > The PyZMQ page says no code changes necessary so basically all I did was
  > change to 3.0.0a. I've tested REQ-REP, REQ-XREP and these setup seems to
  > work just fine. I've written a testing code which flows as follows:
  Can you check with 3.0 head (git at github.com:zeromq/zeromq3-0.git) and 
  use ROUTER instead of XREP? There's an unreleased patch there that 
  should make ROUTER fully compatible with 2.x XREP semantics.
  I will try this out tomorrow when I resume.  Just a clarification though - in the current python binding (pyzmq), there is no zmq.ROUTER.   

pyzmq master has zmq.ROUTER/DEALER.  Note that you can just add constants that pyzmq is missing, by simply adding:

zmq.ROUTER = 11
zmq.DEALER = 12

# these values are specific to zeromq >= 3.0, since ROUTER/DEALER==XREP/XREQ in 2.1.    

at the beginning of your program. As far as pyzmq is concerned, all of the socket types, etc. are just numbers.

pyzmq is all ready to cut a release (I even built an entire 2.1.8 release two weeks ago, before 2.1.8 was demoted to a release candidate), so as soon as zeromq cuts 2.1.9 pyzmq will follow suit.    


Please excuse my ignorance also,  but I'm quite new with Git and its lingo :).  I've checked out the current zeromq3 source and I'm getting the following in MSVC++:    

Performing Pre-Build Event...          1 file(s) copied.  Compiling...  zmq.cpp  <path>\zeromq3-0\src\zmq.cpp(595) : error C3861: 'wsa_error_to_errno': identifier not found  

  zeromq-dev mailing list
  zeromq-dev at lists.zeromq.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110818/e864cf0b/attachment.htm>

More information about the zeromq-dev mailing list