[zeromq-dev] Android support in 2.1 master

Pieter Hintjens ph at imatix.com
Thu Aug 11 17:28:21 CEST 2011


On Thu, Aug 11, 2011 at 10:05 AM, Martin Sustrik <sustrik at 250bpm.com> wrote:

> IIRC, configure should produce an error saying: such and such platform
> not supported. Take the platform name as reported and create a new
> section in configure.in, check the sections for other platforms and do
> something similar. One of the commands there IIRC is to define
> appropriate ZMQ_HAVE_* macro.

Thanks. There's no native building on Android, only cross-compilation.
I'd tried adding a section in configure.in, but I've no idea how to
get configure to use it. --build and --host don't do it.

-Pieter



More information about the zeromq-dev mailing list