[zeromq-dev] NoClassDefFoundError: Could not initialize class org.zeromq.ZMQ

Rugemalila Jeremiah Ngemera jeremi16us at gmail.com
Mon Aug 8 11:42:38 CEST 2011


To who it may concern,

I have very new to ZeroMQ. My colleague wrote a web application which i am
suppose to go through and continue developing it.
We are running springMVC, after running mvn jetty:run, the system runs,

but when ever the application enter a block which is suppose to run ZMQ, it
throws a NoClassDefFoundError.

NB: i have tried to run on three diff OS (Ubuntu 11.04, Ubuntu 10.10 and
Windows Vista) and got the same error.


This is the issue i raise in GitHub, few weeks ago. After a continues
research, if found a fix but i dont understand the fix.

In ubuntu, it seems like its unable to locate where the ZeroMQ lib are. Thus
to fix this, i appended LD_LIBRARY_PATH=/usr/local/lib

to my envromental variables in /etc/profile.d/env_var.sh

Now the problem is, when ever i want to run jetty or tomcat for that matter,
i need to ensure before i do so, i reset /etc/profile

so that the session i am currently in can see this variable.


Thank you.

Attached is the stack trace of the error i get.

-- 
Regards,
*Jeremiah R.*

Email : jeremi16us at gmail.com
Mobile: +601 7377 2760
Twitter <http://twitter.com/#!/jeremi16us> |
Facebook<http://www.facebook.com/jeremi16us>
 | Google+ <https://plus.google.com/114159533755192395235>

"Please take a moment to think of the ENVIRONMENT before you PRINT this..!!
Love the Environment n' Go Green"

Sent from my DELL inspiron 1420
"Change starts now!!"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110808/8ea42b62/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: NoClassDefFoundError.pdf
Type: application/pdf
Size: 30147 bytes
Desc: not available
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20110808/8ea42b62/attachment.pdf>


More information about the zeromq-dev mailing list