[zeromq-dev] Zero-copy message API
Pieter Hintjens
ph at imatix.com
Sun Apr 3 11:16:33 CEST 2011
Hi Martin,
One thing that seems to consistently trip up users is the zero-copy
message API, and the way it's presented. That is, reading the docs,
there's no hint that zmq_msg_init_data() is much harder to use
properly than zmq_msg_init_size().
For the 3.0 API, it could be neat to slice these apart and make it
clearer that there is a simple way for 90% of apps, and a complex way
for 10%.
For example, zmq_msg_init() might take a size argument, and merge the
functionality of zmq_msg_init_size(), and then we could rename
init_data to zmq_msg_init_zerocopy().
-Pieter
More information about the zeromq-dev
mailing list