[zeromq-dev] invalid ELF headers

Brazil web brazilweb at gmail.com
Wed Sep 8 03:47:23 CEST 2010


Hello,

I installed zeromq on ubuntu 10,04 and the compilation went through without
any errors.

However when i try to run the python test, it results in this error:

jerome at VM1:~/zeromq/pyzmq-2.0.7$ python setup.py test
running test
Traceback (most recent call last):
  File "setup.py", line 144, in <module>
    'Topic :: System :: Networking'
  File "/usr/lib/python2.6/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/usr/lib/python2.6/distutils/dist.py", line 975, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.6/distutils/dist.py", line 995, in run_command
    cmd_obj.run()
  File "setup.py", line 59, in run
    tests = TestLoader().loadTestsFromNames(testfiles)
  File "/usr/lib/python2.6/unittest.py", line 613, in loadTestsFromNames
    suites = [self.loadTestsFromName(name, module) for name in names]
  File "/usr/lib/python2.6/unittest.py", line 576, in loadTestsFromName
    module = __import__('.'.join(parts_copy))
  File "/home/jerome/zeromq/pyzmq-2.0.7/zmq/__init__.py", line 26, in
<module>
    from zmq import _zmq
ImportError: /home/jerome/zeromq/pyzmq-2.0.7/zmq/_zmq.so: invalid ELF header

What do i need to do to fix this?

Thanks
Jerome
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100907/d5b598fa/attachment.htm>


More information about the zeromq-dev mailing list