[zeromq-dev] any hints?

Martin Sustrik sustrik at 250bpm.com
Tue Oct 26 17:43:48 CEST 2010


What do you actually see? A segfault?

Martin

On 10/26/2010 02:03 PM, Andrew Hume wrote:
> i realise its crass to ask for help in a complicated program, but i'd
> appreciate any hints on what to look at.
> i am running version 2.0.9 on a red hat enterprise 5.4 system
> (actually several nodes identically setup).
>
> the program (digest) has a main thread which opens several sockets
> successfully.
> it passes the zmq context to a few other threads, who then open one
> or two zmq sockets to work on.
>
> the problem is this: digest fails to work on exactly one system
> (nisus01) in the following way:
> any call to zmq_socket in a thread other than the main thread fails with
> no useful errno.
> (the types include ZMQ_SUB and ZMQ_PUSH.) the same binary and same libraries
> work on other nodes just fine. similiar programs using zmq run just fine
> on nisus01.
>
> i've asked my sysadmin to reboot nisus01 to see if that changes anything.
> is there anything else to look at? i've run everything with valgrind to
> make sure
> i'm not stomping on memory. is there some non-thread safe weakness with
> zmq_socket?
>
> andrew
>
> ------------------
> Andrew Hume (best -> Telework) +1 623-551-2845
> andrew at research.att.com <mailto:andrew at research.att.com> (Work) +1 none
> currently
> AT&T Labs - Research; member of USENIX and LOPSA
>
>
>
>
>
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev




More information about the zeromq-dev mailing list