[zeromq-dev] No uuid-dev on Centos

Eric Bell eric at ericjbell.com
Mon Nov 15 17:10:37 CET 2010


Thanks Martin. I'll check it out. I'm a packaging ignoramous, but I 
think that the RHEL packages work, and then there's something called 
EPEL that provides additional packages.

I may back track on my choice of Centos and try to get a version of 
Ubuntu running on Amazon EC2. I've been trying to find a pre-built 
Amazon Machine Image to use as a starting point and it's proving to be 
quite a puzzle of operating system, backing store, package repositories 
that actually work, etc ... last night though I think I might have found 
a path that doesn't require that I build my own AMI from scratch.

Anyway, that's the only reason I ended up with CentOS, and I'd really 
like to stick with Ubuntu if I can because that is what I know.

--eric

On 11/15/2010 07:30 AM, Martin Sustrik wrote:
> On 11/15/2010 03:54 AM, R P Herrold wrote:
>> On Sun, 14 Nov 2010, Eric Bell wrote:
>>
>>> I tried installing 0MQ on Centos 5.4 (5.5?) ... got an error message
>>> saying that I needed to install package uuid-dev. I couldn't find that
>>> package but there was one called uuid-devel, but installing that didn't
>>> help.
>>
>> the uuid-devel headers in Centos 5 series are in glibc-devel,
>> as they were split out to a standalone package later after the
>> 5 series was stabilized
>
> I am not a packaging expert but does Centos differ from RHEL in any way?
> On RHEL the uuid functions are in e2fsprogs package IIRC.
>
> Martin





More information about the zeromq-dev mailing list