[zeromq-dev] problem building pyzmq

eric eric at ericjbell.com
Sun Nov 14 00:25:11 CET 2010


> As I mentioned earlier today, pyzmq releases can be found at
> http://github.com/zeromq/pyzmq/downloads

I must have gotten confused between your comment that "If you get the 
code via git, it is not a release." versus "releases can be found at 
github" To a newbie like me, these are the same statement. So I kept 
going back to http://www.zeromq.org/bindings:python and on that page I 
see instructions for using git to download source code, and based on 
what you told me that meant that I was downloading a development release.

>     The good news is that I finally got cpython installed and was able to
>     install pyzmq.
>
>
> That's good to hear. Did you have to somehow get cpython separately? If
> so, the cython list should probably be notified that their code isn't
> installing properly.

Separately from what? All I know is that things weren't compiling, then 
I tried to use pip to install cpython but that didn't seem to fix 
things, so I tried easy_install, and now things work.

Right now things are too confused for me know how anything got installed 
on my machine. I will revisit this installation issue at some point when 
I start to build out my Amazon Machine Images where I think I'll be 
using ZeroMQ a bit.

Thanks for your help.

--eric




More information about the zeromq-dev mailing list