[zeromq-dev] Backwards compatibility?

Emmanuel TAUREL taurel at esrf.fr
Wed May 26 08:34:27 CEST 2010


Hello all,

 From the emails exchanged yesterday on the mailing list, I understand 
that the ZMQ API will change between release 2.0.6 and the next one.
(I am talking about the LWM setsockopt() call). This could generate 
trouble for application(s) using this call.

My question is not about this specific LWM change but rather about 
releases compatibility.
Is there any rules regarding compatibility between ZMQ releases (minor 
and/or major)?

Thank's for your answers

Emmanuel Taurel




More information about the zeromq-dev mailing list