[zeromq-dev] PGM protocol not avaliable

tradermbox-zmq at yahoo.com tradermbox-zmq at yahoo.com
Fri May 21 15:23:02 CEST 2010


I am not sure if your answer is relevant since my testing code works on Fedora12 with pgm.

I have successfully compiled zeromq with pgm and tested pgm on Fedora 12 but have NOT been able to do so with RHEL4 or 5 (gcc 4.1.2). The error was shown in the previous email. Previous post suggests a get around but the resultant library does not work with PGM.






________________________________
From: Steven McCoy <steven.mccoy at miru.hk>
To: 0MQ development list <zeromq-dev at lists.zeromq.org>
Sent: Thu, May 20, 2010 9:48:04 PM
Subject: Re: [zeromq-dev] PGM protocol not avaliable

When previously raised the only point was that ZeroMQ does not support request/reply over PGM:

http://lists.zeromq.org/pipermail/zeromq-dev/2010-January/001912.html

-- 
Steve-o


On 21 May 2010 09:27, <tradermbox-zmq at yahoo.com> wrote:

we are running into a linking problem:
>
>>
>
>/bin/ld: .libs/libzmq_la-txwi.o: relocation R_X86_64_PC32 against symbol `pgm_rs_create' can not be used when making a shared object; recompile with -fPIC
>
>A solution was posted on http://lists.zeromq.org/pipermail/zeromq-dev/2010-May/003586.html
>
>Using the above solution, I managed to "make install" ok. But somehow when I connect to multicast addresses such as: <epgm://eth0;239.192.1.1:7777>, I get errors: Protocol not supported
>
>The above error was shown with tests on both RHEL4 or RHEL5 running gcc 4.1.2. However when I run it on Fedora 12, using gcc 4.3.2., I can connect to PGM
> without problem. I understand that it is a G_GNUC_INTERNAL symbololgy issue but I dont know if the above solution actually prevents ZMQ from running with PGM.
>
>I also tried with ./configure --with-pgm --enable-shared=no. still cannot get PGM to work.
>
>
>_______________________________________________
>>zeromq-dev mailing list
>zeromq-dev at lists.zeromq.org
>http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100521/fae03fa4/attachment.htm>


More information about the zeromq-dev mailing list