[zeromq-dev] PGM protocol not avaliable

tradermbox-zmq at yahoo.com tradermbox-zmq at yahoo.com
Fri May 21 03:27:50 CEST 2010


we are running into a linking problem:


/bin/ld: .libs/libzmq_la-txwi.o: relocation R_X86_64_PC32 against symbol `pgm_rs_create' can not be used when making a shared object; recompile with -fPIC

A solution was posted on http://lists.zeromq.org/pipermail/zeromq-dev/2010-May/003586.html

Using the above solution, I managed to "make install" ok. But somehow when I connect to multicast addresses such as: <epgm://eth0;239.192.1.1:7777>, I get errors: Protocol not supported

The above error was shown with tests on both RHEL4 or RHEL5 running gcc 4.1.2. However when I run it on Fedora 12, using gcc 4.3.2., I can connect to PGM without problem. I understand that it is a G_GNUC_INTERNAL symbololgy issue but I dont know if the above solution actually prevents ZMQ from running with PGM.

I also tried with ./configure --with-pgm --enable-shared=no. still cannot get PGM to work.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100520/54573ac8/attachment.htm>


More information about the zeromq-dev mailing list