[zeromq-dev] Semantic versioning

Brian Buchanan bwb at holo.org
Sat Jun 19 22:15:51 CEST 2010


I'd like to suggest that ZeroMQ adopt "semantic versioning" (see http://semver.org/ ) when the 2.x API settles down and the first stable release is made. (v2.1.0 perhaps?)

Being able to infer API compatibility from the version number is critical when you're building systems that involve many separate software packages, so you don't wind up in "dependency hell".

It's also very helpful to binding maintainers, because we can use zmq_version() and new, ideally, new zmq.h constants ZMQ_MAJOR_VERSION and ZMQ_MINOR_VERSION to determine whether the installed zmq library is compatible and what API features are supported.

Thoughts?



Cheers,

- Brian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100619/376df142/attachment.html>


More information about the zeromq-dev mailing list