[zeromq-dev] 2.0.7 x64 Windows Linker Errors

Jarred Ward jarred at webriots.com
Thu Jun 17 23:03:56 CEST 2010


Got it to build. I hadn't copied the configuration settings from the x86
build to the x64 build.

It'd be nice to get the x64 platform configuration baked into the visual
studio project so we don't have to recreate it every time we grab from the
repository.

Sorry if this caused any confusion.

On Thu, Jun 17, 2010 at 1:49 PM, Jarred Ward <jarred at webriots.com> wrote:

> This is a clean build from the repository. x86 builds fine. x64 gets the
> linker errors.
>
> 2.0.6 builds in a x64 in my environment, so it seems to be something that
> changed in 2.0.7.
>
> Could someone else cross-compile an x64 build on an x86 windows machine to
> see if you can recreate?
>
>
> On Thu, Jun 17, 2010 at 12:18 PM, Pieter Hintjens <ph at imatix.com> wrote:
>
>> Just to eliminate the obvious: is this a clean build or are there
>> possibly old libraries and/or headers lying around somewhere?
>>
>> -Pieter
>>
>> On Thu, Jun 17, 2010 at 9:04 PM, Jarred Ward <jarred at webriots.com> wrote:
>> > I don't have time at the moment to figure out what's going on, but
>> here's
>> > the build output:
>> > ...
>> > 1>..\..\..\src\zmq.cpp(106): warning C4273: 'zmq_msg_init' :
>> inconsistent
>> > dll linkage
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100617/2ad44bac/attachment.html>


More information about the zeromq-dev mailing list