[zeromq-dev] STREAM_UPSTREAM/DOWNSTREAM confusing?
ph at imatix.com
Fri Jun 11 21:06:38 CEST 2010
Have a look at http://www.zeromq.org/draft:explicit-patterns, see what you
Sent from my Android mobile phone.
On Jun 11, 2010 6:11 PM, "Matt Weinstein" <mattweinstein at gmail.com> wrote:
In re: patterns UPSTREAM and DOWNSTREAM are a bit ambiguous, e.g. some folks
think "the packets will go DOWNSTREAM" vs. UPSTREAM. I know we're back to
the verb/noun/adverb/whatever argument, but if you have to think about it...
I've quit trying and am using the following (less poetic) #defines instead:
#define ZMQ_STREAM_SOURCE ZMQ_DOWNSTREAM
#define ZMQ_STREAM_SINK ZMQ_UPSTREAM
IMO this makes the code a bit more readable at a glance.
(And food for thought re: the 0MQ 3.x API :-) )
zeromq-dev mailing list
zeromq-dev at lists.zeromq.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the zeromq-dev