[zeromq-dev] STREAM_UPSTREAM/DOWNSTREAM confusing?
cremes.devlist at mac.com
Fri Jun 11 18:24:38 CEST 2010
On Jun 11, 2010, at 10:28 AM, Matt Weinstein wrote:
> In re: patterns UPSTREAM and DOWNSTREAM are a bit ambiguous, e.g. some folks think "the packets will go DOWNSTREAM" vs. UPSTREAM. I know we're back to the verb/noun/adverb/whatever argument, but if you have to think about it...
> I've quit trying and am using the following (less poetic) #defines instead:
> #define ZMQ_STREAM_SOURCE ZMQ_DOWNSTREAM
> #define ZMQ_STREAM_SINK ZMQ_UPSTREAM
> IMO this makes the code a bit more readable at a glance.
I like it.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the zeromq-dev