[zeromq-dev] STREAM_UPSTREAM/DOWNSTREAM confusing?
mattweinstein at gmail.com
Fri Jun 11 17:28:28 CEST 2010
In re: patterns UPSTREAM and DOWNSTREAM are a bit ambiguous, e.g. some
folks think "the packets will go DOWNSTREAM" vs. UPSTREAM. I know
we're back to the verb/noun/adverb/whatever argument, but if you have
to think about it...
I've quit trying and am using the following (less poetic) #defines
#define ZMQ_STREAM_SOURCE ZMQ_DOWNSTREAM
#define ZMQ_STREAM_SINK ZMQ_UPSTREAM
IMO this makes the code a bit more readable at a glance.
(And food for thought re: the 0MQ 3.x API :-) )
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the zeromq-dev